This page provides details on how to use the Plate Editor tool.

The Plate Editor is found in the Visualizations band, which by default is under the Tools tab in the Workspace.

Note: You may have to switch to Advanced mode to view the Tools tab, or you may drag the Visualizations band onto your ribbon under a different tab (these changes can be made through the ribbon configuration dialog, accessed by clicking the ribbon icon in the top right corner of the Workspace).

 

The main interface of the Plate Editor is shown in Figure 1.

Plate_Editor

Figure 1

The controls in the Plates band allow you to add, duplicate, or delete a plate set-up, as well as rename a set-up by clicking on the plate name.  This functionality is similar to the Layout and Table Editors.

The Plate Editor’s Experiment band contains tools needed to gather data from the Workspace and annotate it:

  • Annotate Experiment allows you to provide a description of your experiment following the MIFLOWCYT standard.
  • Read Samples from Group will pull data in from the Workspace using whichever group is currently selected.  Click this to match samples in the current group to the wells in the current plate.
  • Read Attributes from Group will allow you to view or modify the keywords existing in files added to the Plate Editor.  You will notice when you click this the Plate Name, Experiment ID, and Plate ID fields populate above the plate graphic, as shown in Figure 3.

 

                                                                              Figure 3

 

Each of the wells is now annotated with whatever number of keywords could be extracted from the FCS files; the number of keywords associated with each well is listed in the lower righthand corner of the well block, as shown in Figure 4. You will also see that the selected well highlights with a tan color. If you hold down the shift key and click another well, all wells between the two you clicked on will be selected; you can also hold down the ctrl/cmd key to selectively choose multiple wells. If you click the column number (i.e. the 1) or the row letter (i.e. the A) then you can quickly select an entire row or column.

                                                    Figure 4 

If just one well is selected, the Keyword/Values — Selected Well box in the right panel will populate with the keywords associated with the selected well.  If you would like to strip one or more of the keywords off of that well click the red “X” to the left of the keyword. An example of these values is displayed in Figure 5.

                                                                                 Figure 5

 

To add new keywords to a plate, simply type the keyword label and value into the Input Dialogue box, as shown in figure 6(a). When you have completed typing the values click the ‘Add’ button directly to the left. The keyword pair will then appear in the Keyword/Values — Drag to Wells box, as shown in Figure 6(b).

 

       

(a)                                                                          (b)

Figure 6

 

Then, as the name of the panel implies, to apply this keyword to one or more files simply drag it and drop it onto a well, a row, a column, or all wells (by dragging and dropping to the blank box at the intersection of the row and column identifiers, in the top left corner of the plate). When a keyword has been applied to a well or group of wells, those wells will be outlined with a green border. Click on different keywords listed in the Keyword/Values — Drag to Wells box to see which wells that keyword has been applied to. See Figure 7 for an example.

 

Figure 7

 

You can also drag keywords to a staging well, as shown in Figure 8.  Staging wells allow for sets of keywords to be assembled and then applied to one or more wells.  You will notice that the keyword counter in each staging well box increments as you add new keywords.

 

Figure 8

  • Once you have completed annotating the wells, click  Apply Plate Keywords to Group  (located in the Experiment band), and everything that you have added to the wells will appear as available keywords to be displayed, used for iteration, or used for sorting throughout any other part of FlowJo.

 

The File tab, shown in Figure 9, contains the Document band. Located here are tools for exporting and importing metadata to and from external sources. Of particular interest is importing data from a spreadsheet, covered in Importing Metadata From a CSV file. Another useful tool is Save As Template. This will create a Workspace template (WSPT) file. Templates with plate definitions will attempt to associate keywords and (indirectly) groups to new samples based on matching PLATE ID and WELL ID keywords.

 

Figure 9

 

The Edit tab, shown in Figure 10, contains the Clipboard and Select bands (by default), which allow for expediting your analysis process — tools include Copy, PasteSelect All, Invert Selection, Fill tools, and more.  A useful tool in the Select band is Make Group, which will create a new group in the workspace from any selection of wells.

                                                              Figure 10

 

The Tools tab, shown in Figure 11, can be used to format the appearance of the plates.  The Settings band contains options for displaying the attributes, creating a heat map of numerical keywords, and coloring or scaling well borders. The Configure band includes a tool for setting up a dilution series. You can also add keywords from a file via the Keywords band.

 

Figure 11

Finally, the Layout Editor supports a plate object, which is a variation of a statistics grid for visualizing statistics in a full plate view.

 

See Also: